Follow

API Versioning

You may use the request header X-API-Version to specify your expected API version. The currently supported versions are:

3.0.0

If the version header is omitted, then by default the most recent version of the API will be used to process your request. If this default version is not backwards-compatible with the (presumably older) version that you expect, then the request processing and response may be unexpected or erroneous.

If the version header is supplied and matches a supported version, then that version will be used to process the request.

If the version header is supplied and does not match a supported version, then the response will have status 501.

% curl -H "X-API-Version: 0.8.0" https://app.liquidplanner.com/api/account 
{
"message": "The version you requested is not implemented.",
"error": "NotImplemented",
"type": "Error"
}
Status: 501
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk